火山安卓平台新手入门教程

作者:创世魂

 

● 教程说明

本篇教程共分为五个部分:

第一:产品安装。

第二:安卓项目建立和程序编写。

第三:编译发布版安卓程序。

第四:学习资源。

第五:常见问题。

 

一、产品安装

 

 

● 产品安装

 

1、打开下载地址:

打开“服务卡背面”的下载地址,选择合适自己的版本下载。

为保障售后服务,务必添加官方QQ群:895033329

 

2、下载后会看到如下文件。

 

 

● 安装步骤

 

1、打开安装包

打开后直接点击“下一步”

 

2、选择“我同意”,继续点击“下一步”

 

3、此处可看到“更新说明”等软件信息,继续点击“下一步”

 

4、程序默认安装路径为当前系统盘(通常为C盘),建议点击“浏览”更换安装路径。

注意:安装路径不能为中文。

 

5、根据需要勾选所需安装部分后,继续点击“下一步”

 

6、继续“下一步”

 

7、根据需求选择后,继续“下一步”

 

8、点击“安装”

 

9、安装结束后,建议勾选“VS2013运行环境”,否则火山可能无法正常运行。

 

10、“VS2013运行环境”安装。

勾选“我同意”,点击“安装”

 

11、安装完成后“关闭”即可。

 

12、安装完毕后,桌面上可以看到“火山安卓软件开发平台”

 

 

● 配置jdk/adk环境

 

1、打开火山官网:http://www.voldp.com/android.html,找到如下内容,下载系统对应版本的环境包。

 

2、如果下载“64位”版本,下载完毕后,可看到此文件。

 

3、打开压缩包一般都可以直接看到压缩包注释。

注释中有详细说明:将压缩包内的“SDK”文件夹,解压到火山安装目录的“plugins\vprj_android”目录内即可。

 

4、打开火山“plugins\vprj_android”目录,将压缩包内的“sdk”文件夹,解压到当前目录下即可。

 

5、配置火山SDK,打开“工具->选项”。

 

6、如果使用火山提供的SDK,需保持保持sdk安装目录为空。

 

7、如果使用自己安装的sdk需要指定其根目录

 

 

二、安卓项目建立和程序编写

 

● 通过一个具体的火山程序来演示

 

1、打开火山程序。

选择“文件->新建->项目”,也可以使用快捷键“Ctrl+Shift+N”

也可以点击“欢迎页”中的“新建项目”。

 

2、左侧选择“空白安卓程序”,右侧选择“空窗口”

依次填写“项目名称”“所处位置”“解决方案名称”

最后点击“确定”即可。

 

3、最后会在“所处位置”创建以下文件和目录。

(1)其中“test.vsln”文件是解决方案主文件,打开一个火山项目都是通过此文件来打开。

(2)“test”是当前解决方案中的其中一个项目,火山的解决方案可以建立多个项目进行同时管理,每个项目都可以独立编译一个安卓程序并且互不干扰。

 

4、创建后:

(1)其中“test”解决方案名称对应上图中的“test.vsln”文件。

(2)“模块”是当前项目自动引用的核心库模块,默认引用“Java基本类”“安卓基本类”模块。

如果需要引用更多模块,请看 模块的封装和使用方法中的“三、如何在程序中使用火山模块”

(3)“test”项目名称对应上图中的“test”目录。

(4)“main.v”当前文档名称位于“test/src/”目录中,src目录为火山自动生成,知道即可无需了解其含义。

(5)另外在“test”项目目录中,还存在一个“test.vprj”的文件,此文件为当前项目结构文件,存储了当前项目结构信息。

注意:如果新建了一个“test2”的项目,那么结构文件就会是“test2.vprj”

 

5、一个解决方案中建立多个项目

(1)选择“文件-新建-项目”


(2)选择“空窗口”后,输入“项目名称”“所处位置”不建议修改,方便管理整体解决方案,保持原样即可。


(3)建立完成后界面如下。


(4)建立完成后“所处位置”处会生成一个新的文件夹“test2”,此文件夹就是项目2的文件夹。


(5)右键项目“test”选择“设置为活动项目”,可进行项目切换。


(6)切换项目后状态。


6、在“启动类”的代码区域右键,可以打开“启动类”的界面设计器。

 

7、打开后如下图所示。

左侧:显示了所有的窗口组件。

右侧:显示了窗口组件部分属性。

注意:“并非”所有属性都能够正常的进行设置。

例如:你在使用“按钮”时,无法在右侧属性栏设置“垂直滚动条滑块图”属性。

因为“按钮”并不具备此属性。

 

7、点击“按钮”可拖放到“界面设计器”内,右侧的“文本”可修改标题。

点击“确定”可保存布局。

8、保存后如下图所示。

 

9、如有“多个窗口”,想要打开指定窗口的设计器,需要在指定窗口类代码区域右键。

 

10、右键“按钮”,选择“添加‘按钮1’的事件接收方法”

 

11、选择“按钮_被单击”,点击“添加”

 

12、添加事件后如下图所示。

 

13、执行单击事件需要在“返回”之前书写代码。

“如果”条件命令内,指定“来源对象==按钮1”,就可以判断按钮1被单击。

在此行代码的下方,填写“提示信息框()”方法,就可以弹出一个信息框。

“//”双斜线后面的文本代表注释。

注意:在火山中编写代码无需输入中文,只需要填写首拼即可完成代码输入。

例如:“如果”只需要输入“rg”

 

 

● 调试程序

 

1、准备

如果要使用真机调试,将手机和电脑用数据线连接后,需要打开手机“USB调试”

具体打开方式看该手机的帮助手册。

如果要使用模拟器调试,可使用“天天模拟器”“雷电模拟器”

 

2、调试程序

点击绿色的三角按钮可“启动调试”。

或者选择菜单“调试->运行(F5)”同样可启动调试。

3、正常编译后,最终会提示“调试准备工作完成”。

4、真机调试结果:

 

5、也可选择使用模拟器调试,打开“雷电模拟器”,点击右侧“工具条”选择“安装”

 

6、选择APK文件。

根据输出信息中的路径,找到APK位置,选择后点击“打开”

 

7、安装完毕后即可在模拟器桌面看到“火山程序”

 

8、打开程序后,点击“按钮1”就会弹出带有提示图标的“提示信息框”

 

 

 

三、编译发布版安卓程序

 

● 填写包名

 

1、“包名”位于所有程序代码的最上方位置。

通常书写格式为“公司名.程序名”,名称随意。

填写包名,必须保证有一个小数点,并且保证唯一性,不能与其它程序包名重复,以免造成无法安装的后果。

例如:腾讯QQ的包名为“com.tencent.mobileqq ”,当前程序不可填写同样的包名,会造成包名冲突,从而无法安装程序。

注意:确定包名后不能更改,如果程序内有多个“.v”文件,则每个文件都需要填写包名。

程序内多个文件的包名可重复。

 

● 建立密钥文件

 

1、点击菜单“工具->安卓密钥文件建立器”

 

2、填写“姓名”,名称随意,不能为中文。

随后点击“生成到密钥文件”后方的按钮。

 

3、输入“文件名”点击“保存”

 

4、保存后,编辑框内就会出现保存路径。

最后点击“生成”

 

5、点击“确定”即可完成“密钥文件建立”的所有操作。

 

 

● 设置软件信息

 

1、右键项目名称,选择“属性”

 

2、软件必备信息设置。

程序标题程序版本号程序版本名称程序图标以及签名用的密钥文件名

依次填写完毕后,点击“确定”即可。

注意:软件应用市场升级软件通常以“程序版本号”为准,在升级软件时建议修改“程序版本号”

 

 

● 编译发布版本

 

1、点击菜单“生成->生成活动项目”

 

2、在输出栏可看到提示“编译成功”和“APK保存路径”。

 

3、找到输出的APK文件,安装后如下图所示。

可以看到“程序名称”“图标”均被修改。

 

 

四、学习资源

 

● 图文教程

 

1、在线帮助文档查看:http://doc.voldp.com/

左侧列表中的加号可进行收缩。

 

2、离线帮助文档,点击菜单“帮助->帮助手册”即可打开离线帮助文档。

 

● 类库手册

 

1、点击软件左侧“类库手册”,即可查看火山类库所有类或方法。

2、首次打开“帮助页”需要双击,双击打开后即可单击切换要查看的类或方法。

 

3、右键想要打开帮助的方法,选择“显示‘提示信息框’的帮助内容”

 

4、点击后会快速定位“提示信息框”方法。

点击“选择”,可以快速定位“当前方法”“左侧列表”的位置。

 

5、点击“帮助页”向下拖拽,出现“小图标”后可分离“帮助页和代码框”

 

6、“帮助页和代码框”分离效果图。

 

● 官方论坛

 

点击进入官方论坛:http://bbs.voldp.com/forum.php

 

 

五、常见问题

 

1、没有写入权限。

出现这种情况的原因,通常是火山程序安装在了“系统盘”中。

 

  打开项目所处目录,右键空白区域,选择“属性”

 

  选择“安全”在,找到当前登录用户,最后点击“编辑”

 

  找到当前系统登录用户,勾选允许。

 

  会提示正在设置安全信息

 

  点击“确定”

2、如何新建类,常量,变量和方法?

 

3、为什么“界面布局”菜单是灰色的?

 

第一:当前程序正在调试,停止调试即可解决。

第二:当前文件不位于项目中,将该文件加入到一个项目中即可解决。

 

  右键“项目名称”选择“添加->现有文件/文档组”

 

  选择要添加的文件,点击“打开”

 

  添加进项目后,就可以设计该程序中窗口类的布局。

 

4、如何判断当前文件是否不位于项目中?

 

第一:如果已经打开解决方案,查看文档标题第二栏是否为"无"。 。

 

第二:如果尚未打开解决方案,则当前并无文档标题。

 

 

6、火山输出提示缺少XX类?

 

确定类名没有写错,但是火山输出提示“没有找到所指定名称的类"轮播图"”

此时需要添加火山模块,具体可参考“火山模块的封装和使用方法”教程中第三条:如何在程序中使用火山模块。

 

7、调试的项目不是当前打开项目?

多个项目时,注意设置其调试项目为“活动项目”,右键指定项目即可设置,如下图。

 

8、如何判断读属性?

判断读属性的方法很简单,在帮助页中如果遇到“属性读方法”,就证明是读属性。


代码编写如下图:


最终可以将“编辑框1”的内容读取出来显示在信息框中。

 

9、如何判断写属性?

判断写属性的方法很简单,在帮助页中如果遇到“属性写方法”,就证明是写属性。


代码编写如下图:

属性写需要使用“=”连接起来,左边的为属性名右边的内容为属性值

“内容”属性值为“文本型”因此使用时需要使用引号。


最终单击按钮1编辑框1会显示内容。。

 

10、如何判断通常方法?

在帮助页如下位置如果看到“通常方法”四个字,代表本方法为通常方法。


如下图所示,通常方法需要定义变量,通过变量名称去调用。


运行效果如下图:

 

11、如何判断静态方法?

在帮助页中看到“静态方法”四个字,就证明本方法为静态方法。


静态方法调用可直接通过类名访问,不需要定义变量。


运行结果如下图:


 

12、如何判断全局静态方法?

只要类别是“全局静态方法”都可以忽略类名直接访问本方法,并且是全局性质,任何类都可以调用。


代码编写如下图:


运行结果如下图: